Aiuto - Cerca - Utenti - Calendario
Versione completa: Rilascio ufficiale DSecure
.: GBArl.it :. News sulle Console Nintendo - Emulazione - Flash Cards - Trainer > Discussioni Console Nintendo > Discussioni Nintendo DS > Hardware e Utilità DS
Pagine: 1, 2
lucaluca


Tante volte ci siamo ritrovati con cuginetti, fratellini e compagnia bella che solgono rubarci il DS per giocarci , e farci i migliori danni esistenti. Per mettere al sicuro i nostri salvataggi e anche per privatizzare i nostri files sul DS, finalmente esiste qualcosa!

Il progetto è nato su GBArl e lentamente lo sviluppo è arrivato a un buon punto, tanto che posso finalmente rilasciare una release aperta a tutti, ma soprattutto Open Source.

Come Funziona?
Il funzionamento è semplice e comodo, ossia biggrin.gif ... copiamo il DSecure sul nostro DS , seguendo la guida adatta alla nostra flashcard, giochiamo, non appena avremo finito la nostra sessione del gioco basterà aprire il file DSECURE.nds e il DS si spegnerà automaticamente dopo aver applicato la protezione. Non appena avremo ancora bisogno del DS, basterà accenderlo, mettere la password e il DS sarà magicamente senza protezione, pronto alla nostra sessione di gioco.

Compatibilità
Al momento ci è stato possibile testare l'homebrew su poche card e su queste abbiamo delle guide per l'installazione, ma presto (sempre che i betatester si facciano sentire biggrin.gif) potremo vantare di una elevata compatibilità. Le card al momento compatibili con il DSecure e ufficialmente supportate sono :
  • EZ Flash V/V+/Vi
  • AceKard 2 (no 2i)
  • R4 Original
  • Top Toy DS (DSTT)
Installazione
Sul sito ufficiale (fine del post) troverete le guide di installazione per le card supprtate, in continua espansione e in doppia lingua : italiano e inglese

Contribuire
È possibile contribuire al progetto donando nell'apposta pagina per le donazioni nel sito ufficiale, o meglio provando a trovare il metodo di installazione del DSecure sulla vostra flashcard

Open Source
Il progetto è totalmente Open Source ed i sorgenti sono liberamente consultabili e scaricabili dal sito ufficiale. Il tutto è stato rilasciato secondo licenza LFL Luca.Fraga License v0.1 ( Una mia licenza creata ad-hoc, per prevenire alcuni lamerozzi che voglian modificare il sorgente solo per metterci la propria pubblicità e basta... ) Potete consultarla qui : http://pastebin.com/f7214c41b
Ringraziamenti
I ringraziamenti vanno ad Aurelio che mi ha aiutato moltissimo del progetto, e a coloro che, chi più chi meno, mi ha aiutato : .:Mik:., Papero e Nariky (Quest'ultimo per avermi fornito l'idea)
Ovviamente ringrazio tutti i testers, che elenco ad uno ad uno:
» Clicca per leggere lo Spoiler! «

Exit93
pppino
yagamix
matteventu
Alexander Doom
Dark Dragon
lucaluca(Luca.Fraga)
Aurelio
Nariky
MISSIGNO
Robysonic
MarioInside
gp97
gio96b

Mi raccomando testers! Fatevi sentire, che devo ampliare la compatibilità!

** Per piacere, se ho dimenticato qualcuno o ho scritto male qualche homebrew ditelo biggrin.gif


Downloads e sito ufficiale

Sito Ufficiale DSecure
Pagina Downloads ** Vi sconsiglio i mirror MediaFire, anche perchè devo rimuoverli, visto che ci sono stati problemi**
Guide installazione (In continuo aggiornamento)
Pagina Donazioni
Userbar

Supporto

Potete chiedere supporto in questo thread.




UPDATE : DSecure installer : http://www.gbarl.it/index.php?showtopic=63...id=831098&#
salvatore
Complimenti bel progetto una cosa così mancava davvero!!! clap.gif clap.gif clap.gif
lucaluca
CITAZIONE (salvatore @ Saturday 8 August 2009 - 16:25) *
Complimenti bel progetto una cosa così mancava davvero!!! clap.gif clap.gif clap.gif

grazie biggrin.gif

ora sarebbe bello vederlo in home... ma non è una scelta mia tongue.gif
yagamix
homebrew davvero utile e funzionale smile.gif
lucaluca ti faccio i miei complimenti



p.s. riusciremo a vederlo su edge! biggrin.gif
lucaluca
CITAZIONE (yagamix @ Saturday 8 August 2009 - 16:27) *
homebrew davvero utile e funzionale smile.gif
lucaluca ti faccio i miei complimenti
p.s. riusciremo a vederlo su edge! biggrin.gif


Per l'EDGE non so... ho fatto diversi test inconclusivi
~It@chi™
Complimenti clap.gif molto utile come homebrew, adesso lo provo sulla mia r4 visto che per adesso non è compatibile per la CycloDS...
lucaluca
CITAZIONE (~It@chi™ @ Saturday 8 August 2009 - 16:36) *
Complimenti clap.gif molto utile come homebrew, adesso lo provo sulla mia r4 visto che per adesso non è compatibile per la CycloDS...

Difficilmente lo sarà mai... la CycloDS ha un kernel interno
~It@chi™
CITAZIONE (lucaluca @ Saturday 8 August 2009 - 16:37) *
Difficilmente lo sarà mai... la CycloDS ha un kernel interno

Ok, allora mi accontento di usarlo sulla mia r4 originale e ancora complimenti per l'ottimo homebrew smile.gif
Matt3o
Bravo lucaluca clap.gif clap.gif finalmente,era da molto che lo aspettavo,lo vado a provare subito.
daniele73
Salve a tutti,
scusate ma ho letto che non funziona sulla Acekard 2i; io ce l'ho, ma la uso su un nds lite.. ..funziona o non funziona proprio la 2i?
Grazie in anticipo smile.gif
EmaTheLegend
sulla Super Card DSONEi non funziona sad.gif sad.gif .Avvio l'homebrew e dopo 3/4 secondi si spegne il DS. Lo riaccendo, entro nella flashcard e funziona tutto senza chiedere la password
lucaluca
CITAZIONE (daniele73 @ Saturday 8 August 2009 - 16:51) *
Salve a tutti,
scusate ma ho letto che non funziona sulla Acekard 2i; io ce l'ho, ma la uso su un nds lite.. ..funziona o non funziona proprio la 2i?
Grazie in anticipo smile.gif

No, sulla 2i non vuol saperne di andare biggrin.gif ma se vuoi provarci usa la guida della acekard 2 ... male che vada basta reinstallare il kernel della AK2 ... mi raccomando fammi sapere
~It@chi™
CITAZIONE (daniele73 @ Saturday 8 August 2009 - 16:51) *
Salve a tutti,
scusate ma ho letto che non funziona sulla Acekard 2i; io ce l'ho, ma la uso su un nds lite.. ..funziona o non funziona proprio la 2i?
Grazie in anticipo smile.gif

No, funziona solo su R4, EZ V, EZ V+, EZ Vi e AceKard 2 (no 2i)

EDIT: preceduto da lucaluca
Papero
CITAZIONE (lucaluca @ Saturday 8 August 2009 - 16:37) *
Difficilmente lo sarà mai... la CycloDS ha un kernel interno


In genere le card con kernel interno hanno una funzione per far partire automaticamente un file .nds. Forse si potrebbe provare a sfruttare questa funzione.

Comunque bravi! Alla fine ci siete riusciti wink.gif
lucaluca
CITAZIONE (Papero @ Saturday 8 August 2009 - 16:56) *
In genere le card con kernel interno hanno una funzione per far partire automaticamente un file .nds. Forse si potrebbe provare a sfruttare questa funzione.

Comunque bravi! Alla fine ci siete riusciti wink.gif


Beh biggrin.gif sarebbe sufficiente capire come utilizzare quel file con estensione evo
PhantomEdo
Scusate la mia ignoranza, ma come faccio a patchare l' homebrew? huh.gif
Non ce n'è uno già patchato per EZVi? biggrin.gif
Grazie. smile.gif

Edit: credo non userò questo homebrew... wink.gif
oppure se qualcuno mi posta il ink dove scaricarlo già patchato... wink.gif
Grazie lo stesso
DsFaN_96
grandissimo lucaluca!!!questo homebrew mi serviva proprio!:D
Matt3o
Ok messo nella mia ez vi funziona tutto perfettamente yahoo.gif ,però avrei un consiglio,che quando si scrive la password non si spegne il ds ma fa entrare nella flash così si perde meno tempo.Comunque è eccezzionale complimenti clap.gif
giuseppedestiny
Su r4sdhc l'ho avviato si è chiuso in 3 secondi ho riaperto il ds ed è rimasta la scritta loading =(. ora formatto e riprovo smile.gif
lucaluca
CITAZIONE (PhantomEdo @ Saturday 8 August 2009 - 17:05) *
Scusate la mia ignoranza, ma come faccio a patchare l' homebrew? huh.gif
Non ce n'è uno già patchato per EZVi? biggrin.gif
Grazie. smile.gif


c'è tanto di bella guida nel sito ufficiale , e c'è una pagina dedicata alle DLDI ( http://it.dsecure.wikia.com/wiki/DLDI ) e in ogni caso i file delle DLDI li trovi nel kernel (cartella moonshl, file ez5s.dldi)

(Attenzione : ho recentemente scoperto che l'homebrew non va con EZ5i + SDHC + kernel 200, ho provato a farci un fix... provate ad utilizzare questo se avete quest'accoppiata e soprattutto basta estrarre e provare, è un kit pronto : http://dl.getdropbox.com/u/1288184/DSECURE/DSecureEZ.zip )

(Chiunque abbia delle R4 Fake o flashcard non compatibili (ancora) mi mandi un MP col suo indirizzo messenger biggrin.gif, che proveremo ad adattarlo alle varie card)
Aurelio
CITAZIONE (giuseppedestiny @ Saturday 8 August 2009 - 17:14) *
Su r4sdhc l'ho avviato si è chiuso in 3 secondi ho riaperto il ds ed è rimasta la scritta loading =(. ora formatto e riprovo smile.gif

La versione R4 è compatibile solo con la versione originale della R4. Per farla funzionare su R4 cloni copia il file .DAT del firmware della tua R4 nella cartella DSecure e rinominalo in CRYPT.dss(cancellando il vecchio file).
Così dovrebbe funzionare smile.gif
EDIT: Errore mio, questo metodo non funziona.
enyo+
appena riesco la provo sulla m3 simply e real...
giuseppedestiny
CITAZIONE (Aurelio @ Saturday 8 August 2009 - 16:21) *
La versione R4 è compatibile solo con la versione originale della R4. Per farla funzionare su R4 cloni copia il file .DAT del firmware della tua R4 nella cartella DSecure e rinominalo in CRYPT.dss(cancellando il vecchio file).
Così dovrebbe funzionare smile.gif
EDIT: Errore mio, questo metodo non funziona.


Infatti non funziona ha solo cancellato il file .nds
nariky
Sono davvero contento che il dsecure possa esservi utile wink.gif
Kroma91RM
xD per superdcard non ho trovato nulla, è in programma una guida?

nella cartella c'è il txt password è ho capito cosa fare. nell'altro c'è scritto ez5sys.bin che ci devo fa?
lucaluca
CITAZIONE (Kroma91RM @ Saturday 8 August 2009 - 18:36) *
xD per superdcard non ho trovato nulla, è in programma una guida?

nella cartella c'è il txt password è ho capito cosa fare. nell'altro c'è scritto ez5sys.bin che ci devo fa?


allora biggrin.gif

1- scarica http://eng.supercard.sc/download/scdssdhc_dldi_source.zip ed estraine il scdssdhc.dldi e patchachi il DSecure
2- Apri il filename.txt e scrivici MSFORSC.NDS

se funziona fammi sapere biggrin.gif
GiuH
per r4 original testato e funzionante seguendo guida istallazione
complimenti clap.gif
lucaluca
CITAZIONE (GiuH @ Saturday 8 August 2009 - 19:29) *
per r4 original testato e funzionante seguendo guida istallazione
complimenti clap.gif

grazie grazie biggrin.gif ... sinceramente sono molto contento che vi piaccia a voi tutti... però un po di complimenti li ripasso a Nariky che ha avuto l'idea di tutto

ARGH : che errore grammaticale
nariky
Grazie lucaluca ma grazie anche a te perchè hai creato questo homebrew da una mia richiesta
Kroma91RM
lucaluca ho provato sulla mia dsonesdhc (che se non sbaglio patcha automaticamente con la dldi).

allora avvio il prog, si spegne e quando riaccendo esce scritto: "No Find English Ver! Please turn off NDS!" vado a inserire la msd nel lettore, apro la cartella e noto che si è cancellato il programmino @_@

ora provo patchando manualmente. va bene lo stesso se uso dsbuff?

Edit provato patchando con dsbuff ma sempre lo stesso però questa volta il file nds nn si è cancellato
GiuH
CITAZIONE (Kroma91RM @ Saturday 8 August 2009 - 20:46) *
vado a inserire la msd nel lettore, apro la cartella e noto che si è cancellato il programmino @_@

confermo accade anche a me non viene visualizzato il file del Dsecure.nds sul pc ma cmq nel ds è presente e funzionante per (Test R4 Original)
PhantomEdo
Qualcuno può postare il link di questo HB già patchato per ez Vi? wink.gif
Grazie lo stesso. smile.gif
lucaluca
CITAZIONE (Kroma91RM @ Saturday 8 August 2009 - 20:46) *
lucaluca ho provato sulla mia dsonesdhc (che se non sbaglio patcha automaticamente con la dldi).

allora avvio il prog, si spegne e quando riaccendo esce scritto: "No Find English Ver! Please turn off NDS!" vado a inserire la msd nel lettore, apro la cartella e noto che si è cancellato il programmino @_@

ora provo patchando manualmente. va bene lo stesso se uso dsbuff?

Edit provato patchando con dsbuff ma sempre lo stesso però questa volta il file nds nn si è cancellato


No.... a quanto pare la SuperCard controlla che il kernel sia stato sostituito con versioni diverse... purtroppo dobbiamo scartarla dalla lista di compatibilità


CITAZIONE (GiuH @ Saturday 8 August 2009 - 20:57) *
confermo accade anche a me non viene visualizzato il file del Dsecure.nds sul pc ma cmq nel ds è presente e funzionante per (Test R4 Original)


Ovviamente non scompare , ma viene sostituito al kernel biggrin.gif un po complicato, ma se conosci il C /C ++ lo capirai semplicemente leggendo il codice sorgente


CITAZIONE (PhantomEdo @ Saturday 8 August 2009 - 22:22) *
Qualcuno può postare il link di questo HB già patchato per ez Vi? wink.gif
Grazie lo stesso. smile.gif



No, non posso... c'è sul sito una guida facilissima, con tanto di link alla pagina che vi indica dove trovare i DLDI patchers... e soprattutto vi dice anche dove nell'ez si trovano i files con estensione DLDI... quindi o non hai letto la guida, oppure devi googlare per trovarti un DLDI patcher o usare la pagina del sito ufficiale...
PhantomEdo
CITAZIONE
No, non posso... c'è sul sito una guida facilissima, con tanto di link alla pagina che vi indica dove trovare i DLDI patchers... e soprattutto vi dice anche dove nell'ez si trovano i files con estensione DLDI... quindi o non hai letto la guida, oppure devi googlare per trovarti un DLDI patcher o usare la pagina del sito ufficiale...

La guida l' ho letta ma non riesco a installare (e aprire) il patcher... wink.gif
In qualche modo me la caverò... spero... wink.gif
-DjGG-
Seppur con un po' di ritardo però volevo farvi i complimenti per l'ottimo lavoro svolto. Grandi ragazzi! Continuate così!
gp97
Ti sei scordato di me pinch.gif Ho testato per SC-Dsonei e per AK2i pinch.gif
lucaluca
CITAZIONE (PhantomEdo @ Sunday 9 August 2009 - 00:01) *
La guida l' ho letta ma non riesco a installare (e aprire) il patcher... ;)
In qualche modo me la caverò... spero... ;)


usa questo... http://chishm.drunkencoders.com/DLDI/downl...l-win32-gui.zip

CITAZIONE (-DjGG- @ Sunday 9 August 2009 - 01:05) *
Seppur con un po' di ritardo però volevo farvi i complimenti per l'ottimo lavoro svolto. Grandi ragazzi! Continuate così!


biggrin.gif Ti ringrazio per i complimenti


CITAZIONE (gp97 @ Sunday 9 August 2009 - 13:17) *
Ti sei scordato di me pinch.gif Ho testato per SC-Dsonei e per AK2i pinch.gif


aggiunto XD
Andrew374
io ti ho mandato un pm con la mia card dry.gif
-DjGG-
Un appunto per i developers: Su N5 non funziona.
lucaluca
CITAZIONE (-DjGG- @ Sunday 9 August 2009 - 20:25) *
Un appunto per i developers: Su N5 non funziona.

Bastava dirmelo su Messenger, e soprattutto non funziona semplicemente perchè devo ancora capire come realizzare una versione adatta ... quindi, c'è speranza...
-DjGG-
CITAZIONE (lucaluca @ Sunday 9 August 2009 - 20:37) *
Bastava dirmelo su Messenger, e soprattutto non funziona semplicemente perchè devo ancora capire come realizzare una versione adatta ... quindi, c'è speranza...


C'è il thread ufficiale qui e ci sono altri utenti che hanno la N5... almeno così si astengono a provarci, c'ho già provato io con esito negativo...

PS: su messenger non ci sei...
lucaluca
CITAZIONE (-DjGG- @ Sunday 9 August 2009 - 20:39) *
C'è il thread ufficiale qui e ci sono altri utenti che hanno la N5... almeno così si astengono a provarci, c'ho già provato io con esito negativo...

PS: su messenger non ci sei...

Non devono astennersi, anche perchè c'è una speranza che mi ci metta al lavoro...

(su messenger sono appena entrato, e in ogni caso sto per andare)

ps. il forum non è una chat biggrin.gif
Gio96b
Renderlo compatibile per la DsTT è possibile?
Se si mi offro come tester per quella card
nariky
Penso che la guida per la dstt sia in arrivo,anche perchè lucaluca possiede quella flashcard
lucaluca
CITAZIONE (Gio96b @ Monday 10 August 2009 - 13:54) *
Renderlo compatibile per la DsTT è possibile?
Se si mi offro come tester per quella card


Ovviamente sarà tempestivo ad aiutarti, come mia abitudine..

per provare se funziona : scarica qua http://dl.getdropbox.com/u/1288184/NDS/ttio.dldi
scarica il DSecure (non utilizzate il mirror mediafire, mi raccomando)
patcha il DSeure con le DLDI
copialo nella root
apri la cartella DSecure
apri il file filename.txt. svuotalo e scrivici TTMENU.DAT
prova il DSecure

fammi sapere!
EmaTheLegend
qualcuno è riuscito a far funzionare questo homebrew sulla supercard dsonei ??? Il problema è che avvio lìhomebrew, si spegne il ds e, quando riaccendo, il file dsecure.nds è scomparso blink.gif blink.gif
lucaluca
CITAZIONE (EmaTheLegend @ Monday 10 August 2009 - 15:09) *
qualcuno è riuscito a far funzionare questo homebrew sulla supercard dsonei ??? Il problema è che avvio lìhomebrew, si spegne il ds e, quando riaccendo, il file dsecure.nds è scomparso blink.gif blink.gif


Non può funzionare su Supercard, test effettuati...

E UNA VOLTA PER TUTTE : il dsecure.nds NON sparisce, ma viene semplicemente rinominato con il testo presente nel file /DSecure/filename.txt, che dovrebbe contenere il nome del loader della card (per questo ci vuole una guida per ogni card...)
Gio96b
Test con DSTT COMPLETATO
ESITO:.......POSITIVO al 100%.......
DSTT da aggiungere alla lista compatibilità
lucaluca
CITAZIONE (Gio96b @ Monday 10 August 2009 - 15:25) *
Test con DSTT COMPLETATO
ESITO:.......POSITIVO al 100%.......
DSTT da aggiungere alla lista compatibilità

bene tra un po scrivo la Guida sul sito
lucaluca
Aggiunta compatibilità con Top Toy DS (DSTT) e scritta la guida relativa sul wiki ufficiale. wink.gif
Questa è la versione 'lo-fi' del forum. Per visualizzare la versione completa con molte più informazioni, formattazione ed immagini, per favore clicca qui.
Invision Power Board © 2001-2019 Invision Power Services, Inc.