Aiuto - Cerca - Utenti - Calendario
Versione completa: Errore con la compilazione di helloWorld
.: GBArl.it :. News sulle Console Nintendo - Emulazione - Flash Cards - Trainer > Discussioni Console Nintendo > Discussioni Nintendo DS > Hardware e Utilità DS
chris9191
Ciao a tutti,
Ho provato a installare dekitPro e paLib, ma quando compilo il file di prova "HelloWorld" mi da un errore.
Vi posto tutto quello che viene scritto nel Prompt:

CODICE
D:\devkitPro\PAlibExamples\Text\Normal\HelloWorld>make clean
clean ...HelloWorld

D:\devkitPro\PAlibExamples\Text\Normal\HelloWorld>make
main.c
arm-eabi-g++ -g -mthumb-interwork -mno-fpu -L/D/devkitPro/PAlib/lib -specs=ds_ar
m9.specs main.o -LD:/devkitPro/PAlib//lib -lpa9 -L/D/devkitPro/libnds/lib -lfat
-lnds9 -ldswifi9 -o build.elf
d:/devkitpro/devkitarm/bin/../lib/gcc/arm-eabi/4.1.2/../../../../arm-eabi/lib/ds
_arm9_crt0.o: In function `CIDLoop':
ds_arm9_crt0.s:(.init+0x2ac): undefined reference to `initSystem'
collect2: ld returned 1 exit status
make[1]: *** [/d/devkitPro/PAlibExamples/Text/Normal/HelloWorld/HelloWorld.elf]
Error 1
make: *** [build] Error 2

D:\devkitPro\PAlibExamples\Text\Normal\HelloWorld>pause
Premere un tasto per continuare . . .


Mi sapete dire cosè?
Come posso fare per risolverlo?
Grazie.
addre_91
Hai scaricato l' ultima versione delle palib dal sito ufficiale? Perchè la penultima dava dei problemi di incompatibilità con il devkit pro.
Sonic220
Ah ecco perché, cavolo io sono stato una settimana senza riuscire a risolvere sto problema.
chris9191
CITAZIONE (addre_91 @ Sunday 24 February 2008 - 11:05) *
Hai scaricato l' ultima versione delle palib dal sito ufficiale? Perchè la penultima dava dei problemi di incompatibilità con il devkit pro.

Potresti linkarmi questa versione?
Grazie.
addre_91
Ecco: http://palib.info/forum/modules/PDdownload...id=3&lid=41, sostituisci i file della cartella palib con questi e poi fai una volta make.
chris9191
CITAZIONE (addre_91 @ Sunday 24 February 2008 - 11:27) *
e poi fai una volta make.

Sarebbe?
Scusa ma sono un pò ignorante in materia... pinch.gif
chris9191
Ho fatto partire build.bat nella cartella helloworld, ma da sempre lo stesso errore!!!!!!!!!
Altri suggerimenti?
addre_91
reinstalla il devkitpro bene... (in un percorso senza spazi)
Sonic220
Continuo anche io ad avere quest'errore, ho seguito le tue istruzioni ed ho installato l'ultima versione del palib e devkitpro (1.4.4)
Ho sostituito i file come hai detto, ma da sempre
make: *** [build] Error 2

come faccio?
ho già provato a reinstallare installare tutto, e sta tutto salvato in c/devkitpro
Papero
Solito consiglio: sega via tutto, devkitPro e PAlib, quindi reinstalla nell'ordine il dkP in c:\devkitPro e PAlib in c:\PAlib. _MAI_ installare PAlib nella directory del devkitPro smile.gif
Sonic220
CITAZIONE (Papero @ Thursday 28 February 2008 - 11:53) *
Solito consiglio: sega via tutto, devkitPro e PAlib, quindi reinstalla nell'ordine il dkP in c:\devkitPro e PAlib in c:\PAlib. _MAI_ installare PAlib nella directory del devkitPro smile.gif

oO
ecco, io installavo in devkitpro Oo
Mi pare fosse scritto così sul wiki
Provato: va.
Perché non si possono installare nella stessa dir poi? Oo
Papero
Perché probabilmente sovrascrive della roba del tipo ds_arm9_crt0.s con una versione più vecchia. Infatti l'errore è dovuto ad una chiamata ad initSystem che nell'ultima versione del devkitPro è stata tolta
Questa è la versione 'lo-fi' del forum. Per visualizzare la versione completa con molte più informazioni, formattazione ed immagini, per favore clicca qui.
Invision Power Board © 2001-2019 Invision Power Services, Inc.